昇腾故障案例详情页

安装openssl-devel时提示so文件冲突

更新时间: 2023/04/18

暂无评分

问题信息

问题来源产品大类产品子类关键字
官方安装部署CANNCANN、openssl-devel

问题现象描述

运行yum install -y openssl-devel命令进行安装时,出现so文件冲突错误。

原因分析

原生包 openssl-libs-1.1.1f-7.h1.eulerosv2r9 和即将安装的 openssl-SMx-libs-1.1.1f-7.eulerosv2r9 包冲突。

不要强制卸载 openssl-libs,因为 ssl 认证的服务依赖这个包,比如 scp或者ssh等服务依赖于这个包的libcrypto.so.1.1库。另外这个包丢失,会导致rpm失效。

解决措施

下载openssl的rpm包,使用rpm命令强制安装。

  1. 新创建一个文件夹并进入。

    mkdir openDown
    cd openDown

  2. 下载openssl的rpm包,通过以下命令下载到当前文件夹。

    yum install --downloadonly --downloaddir=. openssl-devel

  3. rpm命令强制安装。

    rpm -Uvh *.rpm --force

本页内容

该页面对您有帮助吗?
我要评分